import Foundation
let pattern = #"\([^)]*I{3}[^)]*\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"115 There was objective evidence to establish that the enactment of national laws for various mandatory IMO instruments and their amendments (including tacit amendments) were subject to delays and there was a lack of established procedures and commitment from relevant authorities to assist the process (SOLAS 1974, article I; MARPOL, article 1; LL 1966, article 1; III Code, paragraph 4; III Code, paragraph 8; III Code, paragraph 11)."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)