const regex = /(username\:\w*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(username\\:\\w*)', 'g')
const str = `wat:a,username:x,super:man
wat:a,username:,super:man
wat:a,username:999,super:man`;
const subst = `go:home`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);