$re = '/(username\:\w*)/';
$str = 'wat:a,username:x,super:man
wat:a,username:,super:man
wat:a,username:999,super:man';
$subst = "go:home";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;