import re
regex = re.compile(r"(username\:\w*)")
test_str = ("wat:a,username:x,super:man\n"
"wat:a,username:,super:man\n"
"wat:a,username:999,super:man")
subst = "go:home"
result = regex.sub(subst, test_str)
if result:
print(result)