using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[ *([0-9]{3}0)[^]]*\| *([0-9]{3}[^0]) *\]\]|\[\[ *([0-9]{3}1)[^]]*\| *([0-9]{3}[^5]) *\]\]|\[\[ *([0-9]{3}2)[^]]*\| *([0-9]{3}[^2]) *\]\]|\[\[ *([0-9]{3}3)[^]]*\| *([0-9]{3}[^3]) *\]\]|\[\[ *([0-9]{3}4)[^]]*\| *([0-9]{3}[^4]) *\]\]|\[\[ *([0-9]{3}5)[^]]*\| *([0-9]{3}[^5]) *\]\]|\[\[ *([0-9]{3}6)[^]]*\| *([0-9]{3}[^6]) *\]\]|\[\[ *([0-9]{3}7)[^]]*\| *([0-9]{3}[^7]) *\]\]|\[\[ *([0-9]{3}8)[^]]*\| *([0-9]{3}[^8]) *\]\]|\[\[ *([0-9]{3}9)[^]]*\| *([0-9]{3}[^9]) *\]\]|\[\[ *([0-9]{2}0[0-9])[^]]*\| *([0-9]{2}[^0][0-9]) *\]\]|\[\[ *([0-9]{2}1[0-9])[^]]*\| *([0-9]{2}[^1][0-9]) *\]\]|\[\[ *([0-9]{2}2[0-9])[^]]*\| *([0-9]{2}[^2][0-9]) *\]\]|\[\[ *([0-9]{2}3[0-9])[^]]*\| *([0-9]{2}[^3][0-9]) *\]\]|\[\[ *([0-9]{2}4[0-9])[^]]*\| *([0-9]{2}[^4][0-9]) *\]\]|\[\[ *([0-9]{2}5[0-9])[^]]*\| *([0-9]{2}[^5][0-9]) *\]\]|\[\[ *([0-9]{2}6[0-9])[^]]*\| *([0-9]{2}[^6][0-9]) *\]\]|\[\[ *([0-9]{2}7[0-9])[^]]*\| *([0-9]{2}[^7][0-9]) *\]\]|\[\[ *([0-9]{2}8[0-9])[^]]*\| *([0-9]{2}[^8][0-9]) *\]\]|\[\[ *([0-9]{2}9[0-9])[^]]*\| *([0-9]{2}[^9][0-9]) *\]\]";
string input = @"[[1900]] [[1900 en truc|1901]]
[[1901|1900]]
[[1900 en truc|1900]]
[[1900 en truc|1901]]
[[1904 en truc|1901]]
[[1900|1901]]
[[1900 en truc|1901]] [[1900 en truc|1900]] [[1900 en truc|1910]]
[[1940 en truc|1910]]
[[1940|1910]]
\[\[ *([0-9]{3}0)[^]]*\| *([0-9]{3}[^0]) *\]\]
\[\[ *([0-9]{3}1)[^]]*\| *([0-9]{3}[^5]) *\]\]
\[\[ *([0-9]{3}2)[^]]*\| *([0-9]{3}[^2]) *\]\]
\[\[ *([0-9]{3}3)[^]]*\| *([0-9]{3}[^3]) *\]\]
\[\[ *([0-9]{3}4)[^]]*\| *([0-9]{3}[^4]) *\]\]
\[\[ *([0-9]{3}5)[^]]*\| *([0-9]{3}[^5]) *\]\]
\[\[ *([0-9]{3}6)[^]]*\| *([0-9]{3}[^6]) *\]\]
\[\[ *([0-9]{3}7)[^]]*\| *([0-9]{3}[^7]) *\]\]
\[\[ *([0-9]{3}8)[^]]*\| *([0-9]{3}[^8]) *\]\]
\[\[ *([0-9]{3}9)[^]]*\| *([0-9]{3}[^9]) *\]\]
\[\[ *([0-9]{2}0[0-9])[^]]*\| *([0-9]{2}[^0][0-9]) *\]\]
\[\[ *([0-9]{2}1[0-9])[^]]*\| *([0-9]{2}[^1][0-9]) *\]\]
\[\[ *([0-9]{2}2[0-9])[^]]*\| *([0-9]{2}[^2][0-9]) *\]\]
\[\[ *([0-9]{2}3[0-9])[^]]*\| *([0-9]{2}[^3][0-9]) *\]\]
\[\[ *([0-9]{2}4[0-9])[^]]*\| *([0-9]{2}[^4][0-9]) *\]\]
\[\[ *([0-9]{2}5[0-9])[^]]*\| *([0-9]{2}[^5][0-9]) *\]\]
\[\[ *([0-9]{2}6[0-9])[^]]*\| *([0-9]{2}[^6][0-9]) *\]\]
\[\[ *([0-9]{2}7[0-9])[^]]*\| *([0-9]{2}[^7][0-9]) *\]\]
\[\[ *([0-9]{2}8[0-9])[^]]*\| *([0-9]{2}[^8][0-9]) *\]\]
\[\[ *([0-9]{2}9[0-9])[^]]*\| *([0-9]{2}[^9][0-9]) *\]\]
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}