$re = '/\[\[ *([0-9]{3}0)[^]]*\| *([0-9]{3}[^0]) *\]\]|\[\[ *([0-9]{3}1)[^]]*\| *([0-9]{3}[^5]) *\]\]|\[\[ *([0-9]{3}2)[^]]*\| *([0-9]{3}[^2]) *\]\]|\[\[ *([0-9]{3}3)[^]]*\| *([0-9]{3}[^3]) *\]\]|\[\[ *([0-9]{3}4)[^]]*\| *([0-9]{3}[^4]) *\]\]|\[\[ *([0-9]{3}5)[^]]*\| *([0-9]{3}[^5]) *\]\]|\[\[ *([0-9]{3}6)[^]]*\| *([0-9]{3}[^6]) *\]\]|\[\[ *([0-9]{3}7)[^]]*\| *([0-9]{3}[^7]) *\]\]|\[\[ *([0-9]{3}8)[^]]*\| *([0-9]{3}[^8]) *\]\]|\[\[ *([0-9]{3}9)[^]]*\| *([0-9]{3}[^9]) *\]\]|\[\[ *([0-9]{2}0[0-9])[^]]*\| *([0-9]{2}[^0][0-9]) *\]\]|\[\[ *([0-9]{2}1[0-9])[^]]*\| *([0-9]{2}[^1][0-9]) *\]\]|\[\[ *([0-9]{2}2[0-9])[^]]*\| *([0-9]{2}[^2][0-9]) *\]\]|\[\[ *([0-9]{2}3[0-9])[^]]*\| *([0-9]{2}[^3][0-9]) *\]\]|\[\[ *([0-9]{2}4[0-9])[^]]*\| *([0-9]{2}[^4][0-9]) *\]\]|\[\[ *([0-9]{2}5[0-9])[^]]*\| *([0-9]{2}[^5][0-9]) *\]\]|\[\[ *([0-9]{2}6[0-9])[^]]*\| *([0-9]{2}[^6][0-9]) *\]\]|\[\[ *([0-9]{2}7[0-9])[^]]*\| *([0-9]{2}[^7][0-9]) *\]\]|\[\[ *([0-9]{2}8[0-9])[^]]*\| *([0-9]{2}[^8][0-9]) *\]\]|\[\[ *([0-9]{2}9[0-9])[^]]*\| *([0-9]{2}[^9][0-9]) *\]\]/i';
$str = '[[1900]] [[1900 en truc|1901]]
[[1901|1900]]
[[1900 en truc|1900]]
[[1900 en truc|1901]]
[[1904 en truc|1901]]
[[1900|1901]]
[[1900 en truc|1901]] [[1900 en truc|1900]] [[1900 en truc|1910]]
[[1940 en truc|1910]]
[[1940|1910]]
\\[\\[ *([0-9]{3}0)[^]]*\\| *([0-9]{3}[^0]) *\\]\\]
\\[\\[ *([0-9]{3}1)[^]]*\\| *([0-9]{3}[^5]) *\\]\\]
\\[\\[ *([0-9]{3}2)[^]]*\\| *([0-9]{3}[^2]) *\\]\\]
\\[\\[ *([0-9]{3}3)[^]]*\\| *([0-9]{3}[^3]) *\\]\\]
\\[\\[ *([0-9]{3}4)[^]]*\\| *([0-9]{3}[^4]) *\\]\\]
\\[\\[ *([0-9]{3}5)[^]]*\\| *([0-9]{3}[^5]) *\\]\\]
\\[\\[ *([0-9]{3}6)[^]]*\\| *([0-9]{3}[^6]) *\\]\\]
\\[\\[ *([0-9]{3}7)[^]]*\\| *([0-9]{3}[^7]) *\\]\\]
\\[\\[ *([0-9]{3}8)[^]]*\\| *([0-9]{3}[^8]) *\\]\\]
\\[\\[ *([0-9]{3}9)[^]]*\\| *([0-9]{3}[^9]) *\\]\\]
\\[\\[ *([0-9]{2}0[0-9])[^]]*\\| *([0-9]{2}[^0][0-9]) *\\]\\]
\\[\\[ *([0-9]{2}1[0-9])[^]]*\\| *([0-9]{2}[^1][0-9]) *\\]\\]
\\[\\[ *([0-9]{2}2[0-9])[^]]*\\| *([0-9]{2}[^2][0-9]) *\\]\\]
\\[\\[ *([0-9]{2}3[0-9])[^]]*\\| *([0-9]{2}[^3][0-9]) *\\]\\]
\\[\\[ *([0-9]{2}4[0-9])[^]]*\\| *([0-9]{2}[^4][0-9]) *\\]\\]
\\[\\[ *([0-9]{2}5[0-9])[^]]*\\| *([0-9]{2}[^5][0-9]) *\\]\\]
\\[\\[ *([0-9]{2}6[0-9])[^]]*\\| *([0-9]{2}[^6][0-9]) *\\]\\]
\\[\\[ *([0-9]{2}7[0-9])[^]]*\\| *([0-9]{2}[^7][0-9]) *\\]\\]
\\[\\[ *([0-9]{2}8[0-9])[^]]*\\| *([0-9]{2}[^8][0-9]) *\\]\\]
\\[\\[ *([0-9]{2}9[0-9])[^]]*\\| *([0-9]{2}[^9][0-9]) *\\]\\]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);