import Foundation
let pattern = #"\[\[ *([0-9]{3}0)[^]]*\| *([0-9]{3}[^0]) *\]\]|\[\[ *([0-9]{3}1)[^]]*\| *([0-9]{3}[^5]) *\]\]|\[\[ *([0-9]{3}2)[^]]*\| *([0-9]{3}[^2]) *\]\]|\[\[ *([0-9]{3}3)[^]]*\| *([0-9]{3}[^3]) *\]\]|\[\[ *([0-9]{3}4)[^]]*\| *([0-9]{3}[^4]) *\]\]|\[\[ *([0-9]{3}5)[^]]*\| *([0-9]{3}[^5]) *\]\]|\[\[ *([0-9]{3}6)[^]]*\| *([0-9]{3}[^6]) *\]\]|\[\[ *([0-9]{3}7)[^]]*\| *([0-9]{3}[^7]) *\]\]|\[\[ *([0-9]{3}8)[^]]*\| *([0-9]{3}[^8]) *\]\]|\[\[ *([0-9]{3}9)[^]]*\| *([0-9]{3}[^9]) *\]\]|\[\[ *([0-9]{2}0[0-9])[^]]*\| *([0-9]{2}[^0][0-9]) *\]\]|\[\[ *([0-9]{2}1[0-9])[^]]*\| *([0-9]{2}[^1][0-9]) *\]\]|\[\[ *([0-9]{2}2[0-9])[^]]*\| *([0-9]{2}[^2][0-9]) *\]\]|\[\[ *([0-9]{2}3[0-9])[^]]*\| *([0-9]{2}[^3][0-9]) *\]\]|\[\[ *([0-9]{2}4[0-9])[^]]*\| *([0-9]{2}[^4][0-9]) *\]\]|\[\[ *([0-9]{2}5[0-9])[^]]*\| *([0-9]{2}[^5][0-9]) *\]\]|\[\[ *([0-9]{2}6[0-9])[^]]*\| *([0-9]{2}[^6][0-9]) *\]\]|\[\[ *([0-9]{2}7[0-9])[^]]*\| *([0-9]{2}[^7][0-9]) *\]\]|\[\[ *([0-9]{2}8[0-9])[^]]*\| *([0-9]{2}[^8][0-9]) *\]\]|\[\[ *([0-9]{2}9[0-9])[^]]*\| *([0-9]{2}[^9][0-9]) *\]\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
[[1900]] [[1900 en truc|1901]]
[[1901|1900]]
[[1900 en truc|1900]]
[[1900 en truc|1901]]
[[1904 en truc|1901]]
[[1900|1901]]
[[1900 en truc|1901]] [[1900 en truc|1900]] [[1900 en truc|1910]]
[[1940 en truc|1910]]
[[1940|1910]]
\[\[ *([0-9]{3}0)[^]]*\| *([0-9]{3}[^0]) *\]\]
\[\[ *([0-9]{3}1)[^]]*\| *([0-9]{3}[^5]) *\]\]
\[\[ *([0-9]{3}2)[^]]*\| *([0-9]{3}[^2]) *\]\]
\[\[ *([0-9]{3}3)[^]]*\| *([0-9]{3}[^3]) *\]\]
\[\[ *([0-9]{3}4)[^]]*\| *([0-9]{3}[^4]) *\]\]
\[\[ *([0-9]{3}5)[^]]*\| *([0-9]{3}[^5]) *\]\]
\[\[ *([0-9]{3}6)[^]]*\| *([0-9]{3}[^6]) *\]\]
\[\[ *([0-9]{3}7)[^]]*\| *([0-9]{3}[^7]) *\]\]
\[\[ *([0-9]{3}8)[^]]*\| *([0-9]{3}[^8]) *\]\]
\[\[ *([0-9]{3}9)[^]]*\| *([0-9]{3}[^9]) *\]\]
\[\[ *([0-9]{2}0[0-9])[^]]*\| *([0-9]{2}[^0][0-9]) *\]\]
\[\[ *([0-9]{2}1[0-9])[^]]*\| *([0-9]{2}[^1][0-9]) *\]\]
\[\[ *([0-9]{2}2[0-9])[^]]*\| *([0-9]{2}[^2][0-9]) *\]\]
\[\[ *([0-9]{2}3[0-9])[^]]*\| *([0-9]{2}[^3][0-9]) *\]\]
\[\[ *([0-9]{2}4[0-9])[^]]*\| *([0-9]{2}[^4][0-9]) *\]\]
\[\[ *([0-9]{2}5[0-9])[^]]*\| *([0-9]{2}[^5][0-9]) *\]\]
\[\[ *([0-9]{2}6[0-9])[^]]*\| *([0-9]{2}[^6][0-9]) *\]\]
\[\[ *([0-9]{2}7[0-9])[^]]*\| *([0-9]{2}[^7][0-9]) *\]\]
\[\[ *([0-9]{2}8[0-9])[^]]*\| *([0-9]{2}[^8][0-9]) *\]\]
\[\[ *([0-9]{2}9[0-9])[^]]*\| *([0-9]{2}[^9][0-9]) *\]\]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)