using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[Full GC.*?\s(?P<before_full_gc>\d+)K";
string input = @"127776.635: [Full GC127776.636: [CMS: 12058623K->11149597K(12058624K), 28.5725635 secs] 12355879K->11149597K(12478080K), [CMS Perm : 75918K->75548K(262144K)], 28.5729197 secs] [Times: user=28.58 sys=0.01, real=28.57 secs] ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}