import Foundation
let pattern = #"\[Full GC.*?\s(?P<before_full_gc>\d+)K"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"127776.635: [Full GC127776.636: [CMS: 12058623K->11149597K(12058624K), 28.5725635 secs] 12355879K->11149597K(12478080K), [CMS Perm : 75918K->75548K(262144K)], 28.5729197 secs] [Times: user=28.58 sys=0.01, real=28.57 secs] "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)