re = /\[Full GC.*?\s(?P<before_full_gc>\d+)K/
str = '127776.635: [Full GC127776.636: [CMS: 12058623K->11149597K(12058624K), 28.5725635 secs] 12355879K->11149597K(12478080K), [CMS Perm : 75918K->75548K(262144K)], 28.5729197 secs] [Times: user=28.58 sys=0.01, real=28.57 secs] '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end