#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?:<select.*>\n?\s+(.*<option.*>$.*)\n?\s+<\/select>.*)"
Local $sString = "<select name="javaType">" & @CRLF & _
" <option value="boolean">boolean</option> " & @CRLF & _
" <option value="byte">byte</option> " & @CRLF & _
" <option value="char" selected>char</option> " & @CRLF & _
" <option value="double">double</option> " & @CRLF & _
" <option value="float">float</option> " & @CRLF & _
" <option value="int">int</option> " & @CRLF & _
" <option value="long">long</option> " & @CRLF & _
"</select>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")