package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(?:<select.*>\n?\s+(.*<option.*>$.*)\n?\s+<\/select>.*)`)
var str = `<select name="javaType">
<option value="boolean">boolean</option>
<option value="byte">byte</option>
<option value="char" selected>char</option>
<option value="double">double</option>
<option value="float">float</option>
<option value="int">int</option>
<option value="long">long</option>
</select>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}