re = /(?:<select.*>\n?\s+(.*<option.*>$.*)\n?\s+<\/select>.*)/im
str = '<select name="javaType">
<option value="boolean">boolean</option>
<option value="byte">byte</option>
<option value="char" selected>char</option>
<option value="double">double</option>
<option value="float">float</option>
<option value="int">int</option>
<option value="long">long</option>
</select>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end