using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.([a-z]+)\/(?:([a-z]{2})\/)?";
string input = @"http://www.test.net/shop/test-3
http://www.test.net/gb/shop/test-2";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}