// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\.([a-z]+)\/(?:([a-z]{2})\/)?").unwrap();
let string = "http://www.test.net/shop/test-3
http://www.test.net/gb/shop/test-2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}