$re = '/\.([a-z]+)\/(?:([a-z]{2})\/)?/';
$str = 'http://www.test.net/shop/test-3
http://www.test.net/gb/shop/test-2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);