using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SPECGRID([\s\S]*?)\/";
string input = @"MAPAXES -- Generated : Petrel
159589.61 7782837.94 159589.61 7783837.94 160589.61 7783837.94 /
GRIDUNIT -- Generated : Petrel
METRES /
SPECGRID -- Generated : Petrel
3 26 120 1 F /
COORDSYS -- Generated : Petrel
1 120 /
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}