import re
regex = re.compile(r"\s(?=([^\"]*\"[^\"]*\")*[^\"]*$)")
test_str = "{ \"Activity\": \"ShortDescription\": \"01 Emiel Kool BizTallk\", \"Description\": \"01 Emiel Kool aangemmaakt via BizTalk\", \"Properties\": \"AutoPresent\": null, \"BPV\": false }, \"NameSpaces\": \"NameSpace\": \"TIO/Activiteiten\", \"NameSpaceType\": \"ACTIVITIES\", \"FromTime\": \"2015-07-29 00:00:00\" }"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")