package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^0-9A-Za-z ]`)
var str = `abc@123!-245`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}