$re = '/[^0-9A-Za-z ]/m';
$str = 'abc@123!-245';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;