use strict;
my $str = 'abc@123!-245';
my $regex = qr/[^0-9A-Za-z ]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";