$re = '/\S*(?:(?:[a-z][а-я])|(?:[а-я][a-z]))\S*/iu';
$str = 'Здeсь абсолютно комфоpтно вы можете генерировaть тексты-«рыбы» для решения задач в облаcти макетирования.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);