// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?iu)\S*(?:(?:[a-z][а-я])|(?:[а-я][a-z]))\S*").unwrap();
let string = "Здeсь абсолютно комфоpтн о вы можете генерировaть тексты-«рыбы» для решения задач в облаcти макетирования.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}