re = /\S*(?:(?:[a-z][а-я])|(?:[а-я][a-z]))\S*/i
str = 'Здeсь абсолютно комфоpтно вы можете генерировaть тексты-«рыбы» для решения задач в облаcти макетирования.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end