package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/A\/B\/C\/D\/([^\/]+)\/(\w+)?(?:\.(\w+))?\.(?:log|trc)`)
var str = `/A/B/C/D/TEXT1/TEXT2.TEXT3.log
/A/B/C/D/TEXT1/TEXT2.trc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}