$re = '/\/A\/B\/C\/D\/([^\/]+)\/(\w+)?(?:\.(\w+))?\.(?:log|trc)/m';
$str = '/A/B/C/D/TEXT1/TEXT2.TEXT3.log
/A/B/C/D/TEXT1/TEXT2.trc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);