import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/A\\/B\\/C\\/D\\/([^\\/]+)\\/(\\w+)?(?:\\.(\\w+))?\\.(?:log|trc)";
final String string = "/A/B/C/D/TEXT1/TEXT2.TEXT3.log\n"
+ "/A/B/C/D/TEXT1/TEXT2.trc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}