using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"sip:(\d+)@(([a-zA-Z0-9])[a-zA-Z0-9-.]+[a-zA-Z0-9])";
string input = @"sip:123@asdf.asdf";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}