use strict;
my $str = '<p style=\\"text-align:left\\">
<span style=\\"color:Green\\">
<span style=\\"font-size:12pt\\">
<span style=\\"font-family:Times New Roman\\">There is some content for a mm advertisment.</span>
</span>
</span>
</p>
<p style=\\"text-align:left\\">
<span style=\\"color:Green\\">
<span style=\\"font-size:12pt\\">
<span style=\\"font-family:Times New Roman\\">There is some content for a mm advertisment.There is some content for a mm advertismen</span>
</span>
</span>
<span style=\\"color:Red\\">
<span style=\\"font-size:12pt\\">
<span style=\\"font-family:Times New Roman\\">t.There is s</span>
<span style=\\"font-family:Verdana\\">ome content for a mm advertisment.There is some content for a mm advertisme</span>
</span>
</span>
<span style=\\"color:Green\\">
<span style=\\"font-size:12pt\\">
<span style=\\"font-family:Verdana\\">nt.There is some content for a mm adv</span>
<span style=\\"font-family:Times New Roman\\">ertisment.There is some content for a mm advertisment..</span>
</span>
</span>
</p>
/***************************
String tested in my script
***************************/
<p style=\\"text-align:justify\\">
<span style=\\"font-size:12pt\\">
<span style=\\"color:Green\\">
<span style=\\"font-family:Verdana\\">There is some content for a mm advertisment.There is some co</span>
<span style=\\"font-family:Times New Roman\\">ntent for a mm advertisment</span>
</span>
</span>
</p>';
my $regex = qr/<span style=\\?"color:([a-zA-Z\s]*?)\\?">((.|\n)*?)<\/span>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}