import Foundation
let pattern = #"<span style=\\?"color:([a-zA-Z\s]*?)\\?">((.|\n)*?)<\/span>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<p style=\"text-align:left\">
<span style=\"color:Green\">
<span style=\"font-size:12pt\">
<span style=\"font-family:Times New Roman\">There is some content for a mm advertisment.</span>
</span>
</span>
</p>
<p style=\"text-align:left\">
<span style=\"color:Green\">
<span style=\"font-size:12pt\">
<span style=\"font-family:Times New Roman\">There is some content for a mm advertisment.There is some content for a mm advertismen</span>
</span>
</span>
<span style=\"color:Red\">
<span style=\"font-size:12pt\">
<span style=\"font-family:Times New Roman\">t.There is s</span>
<span style=\"font-family:Verdana\">ome content for a mm advertisment.There is some content for a mm advertisme</span>
</span>
</span>
<span style=\"color:Green\">
<span style=\"font-size:12pt\">
<span style=\"font-family:Verdana\">nt.There is some content for a mm adv</span>
<span style=\"font-family:Times New Roman\">ertisment.There is some content for a mm advertisment..</span>
</span>
</span>
</p>
/***************************
String tested in my script
***************************/
<p style=\"text-align:justify\">
<span style=\"font-size:12pt\">
<span style=\"color:Green\">
<span style=\"font-family:Verdana\">There is some content for a mm advertisment.There is some co</span>
<span style=\"font-family:Times New Roman\">ntent for a mm advertisment</span>
</span>
</span>
</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)