package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\/(.*\/){3}`)
var str = `http://localhost:2000/machine/my-test-machine/3
http://localhost:2000/my-test-machine`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}