re = /\/\/(.*\/){3}/m
str = 'http://localhost:2000/machine/my-test-machine/3
http://localhost:2000/my-test-machine'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end