using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (?=
({%.if
(?:
(?>
(?:
(?! {%.if | endif.%}) .
)+
)*
| (?1)
)*
endif.%})
)
(?1)";
string input = @"not interested in
{% if something %}
----------------
{% if something %}
DEEPER
{% endif %}
{% irgendwas %}
{% if something %}
DEEPER
{% if something %}
DEEPEST
{% endif %}
DEEPER
{% endif %}
---- endif ----
{% endif %}
not interested in
{% if otherthing %}
++++++++++++++++
{% if something %}
DEEPER
{% endif %}
{% irgendwas %}
{% if something %}
DEEPER
{% if something %}
DEEPEST
{% endif %}
DEEPER
{% endif %}
++++ endif ++++
{% endif %}
not interested in";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Singleline | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}