import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " (?=\n"
+ " (\\{%.if\n"
+ " (?:\n"
+ " (?>\n"
+ " (?:\n"
+ " (?! \\{%.if | endif.%\\}) .\n"
+ " )+\n"
+ " )*\n"
+ " | (?1)\n"
+ " )*\n"
+ " endif.%\\})\n"
+ " )\n"
+ " (?1)";
final String string = "not interested in\n\n"
+ "{% if something %}\n"
+ " ----------------\n"
+ " {% if something %}\n"
+ " DEEPER\n"
+ " {% endif %}\n"
+ "{% irgendwas %}\n"
+ " {% if something %}\n"
+ " DEEPER\n"
+ " {% if something %}\n"
+ " DEEPEST\n"
+ " {% endif %}\n"
+ " DEEPER\n"
+ " {% endif %}\n"
+ " ---- endif ----\n"
+ "{% endif %}\n\n"
+ "not interested in\n\n"
+ "{% if otherthing %}\n"
+ " ++++++++++++++++\n"
+ " {% if something %}\n"
+ " DEEPER\n"
+ " {% endif %}\n"
+ "{% irgendwas %}\n"
+ " {% if something %}\n"
+ " DEEPER\n"
+ " {% if something %}\n"
+ " DEEPEST\n"
+ " {% endif %}\n"
+ " DEEPER\n"
+ " {% endif %}\n"
+ " ++++ endif ++++\n"
+ "{% endif %}\n\n"
+ "not interested in";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}