re = / (?=
({%.if
(?:
(?>
(?:
(?! {%.if | endif.%}) .
)+
)*
| (?1)
)*
endif.%})
)
(?1)/xm
str = 'not interested in
{% if something %}
----------------
{% if something %}
DEEPER
{% endif %}
{% irgendwas %}
{% if something %}
DEEPER
{% if something %}
DEEPEST
{% endif %}
DEEPER
{% endif %}
---- endif ----
{% endif %}
not interested in
{% if otherthing %}
++++++++++++++++
{% if something %}
DEEPER
{% endif %}
{% irgendwas %}
{% if something %}
DEEPER
{% if something %}
DEEPEST
{% endif %}
DEEPER
{% endif %}
++++ endif ++++
{% endif %}
not interested in'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end