using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"( - .*)| ";
string substitution = @"\1";
string input = @"My Beautiful Video - Hello darling - 19.10.2015 10:00";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}