$re = '/( - .*)| /m';
$str = 'My Beautiful Video - Hello darling - 19.10.2015 10:00';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;