use strict;
my $str = '4548812049400004
5229782641993099
345678000000007
6362970000457013';
my $regex = qr/(?<=\d{6})(\d+)(?=\d{4})/p;
my $subst = 'X';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";