# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\d{6})(\d+)(?=\d{4})"
test_str = ("4548812049400004\n"
"5229782641993099\n"
"345678000000007\n"
"6362970000457013")
subst = "X"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.