re = /(?<=\d{6})(\d+)(?=\d{4})/
str = '4548812049400004
5229782641993099
345678000000007
6362970000457013'
subst = 'X'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result