use strict;
my $str = 'I have ever been prone to seek adventure and to investigate and experiment where <span class=\'me\'>wiser men</span> would have left well enough alone.';
my $regex = qr/(me)(?!([^<]+)?>)/ip;
my $subst = '<span class=\'highlight\'>$1</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";