import re
regex = re.compile(r"(me)(?!([^<]+)?>)", flags=re.IGNORECASE)
test_str = "I have ever been prone to seek adventure and to investigate and experiment where <span class='me'>wiser men</span> would have left well enough alone."
subst = "<span class='highlight'>$1</span>"
result = regex.sub(subst, test_str)
if result:
print(result)