#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Reason to buy: )([A-Za-z]+)"
Local $sString = "Team: Asian<>Reason to buy: leisure" & @CRLF & _
"Team: SouthAmerica<>Reason to buy: educational<>" & @CRLF & _
"Team: Australia<>Reason to buy: commercial" & @CRLF & _
"Team: North America<>Reason to buy: leisure<>" & @CRLF & _
"Team: Europe<>Reason to buy: leisure<>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")