re = /(?<=Reason to buy: )([A-Za-z]+)/m
str = 'Team: Asian<>Reason to buy: leisure
Team: SouthAmerica<>Reason to buy: educational<>
Team: Australia<>Reason to buy: commercial
Team: North America<>Reason to buy: leisure<>
Team: Europe<>Reason to buy: leisure<>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end