import Foundation
let pattern = #"(?<=Reason to buy: )([A-Za-z]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Team: Asian<>Reason to buy: leisure
Team: SouthAmerica<>Reason to buy: educational<>
Team: Australia<>Reason to buy: commercial
Team: North America<>Reason to buy: leisure<>
Team: Europe<>Reason to buy: leisure<>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)