#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\bfloor area:?\s*\K\d+"
Local $sString = ""A beautiful flat on the 3rd floor with floor area: 50 sqm and a lift"" & @CRLF & _
""Newbuild flat. Floor Area: 30 sq.m" " & @CRLF & _
""6 bed house with floor area 50 sqm, lot area 25 sqm""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")