re = /\bfloor area:?\s*\K\d+/mi
str = '"A beautiful flat on the 3rd floor with floor area: 50 sqm and a lift"
"Newbuild flat. Floor Area: 30 sq.m"
"6 bed house with floor area 50 sqm, lot area 25 sqm"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end