using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bfloor area:?\s*\K\d+";
string input = @"""A beautiful flat on the 3rd floor with floor area: 50 sqm and a lift""
""Newbuild flat. Floor Area: 30 sq.m""
""6 bed house with floor area 50 sqm, lot area 25 sqm""";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}