// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<(\/)?[^>]+>").unwrap();
let string = "<SimpleData name=\"HDRNAME\">Uprr #43 Pan Am B #12</SimpleData>";
let substitution = "<$1name>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}