$re = '/\w+\s*=\s*([\w\']+)/x';
$str = 'name = \'Bruce Wayne\' || TrackId = 12 || age =9 && sample = 7 || thisistoolong = \'asda\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);